Как правильно замаскировать Gnome 3 в Gentoo

Я предпочитаю использовать на своем Gentoo-десктопе классический Gnome 2, не используя его форки типа Mate.

Как замаскировать пакеты gnome 3 в gentoo ?

# /etc/portage/package.mask
# GNOME 3 mask
>=app-accessibility/accerciser-3.2
>=app-accessibility/caribou-0.4
>=app-accessibility/orca-3.0
app-admin/eselect-gnome-shell-extensions
>=app-arch/file-roller-3.0
>=app-cdr/brasero-3.0
>=app-crypt/seahorse-3.0
>=app-editors/gedit-3.0
>=app-editors/gedit-plugins-3.0
>=app-text/gtranslator-2.90
>=app-text/evince-3.0
>=app-misc/tracker-0.12
>=app-mobilephone/gnome-phone-manager-0.67
>=app-pda/gtkpod-2.1.0
>=dev-libs/folks-0.6
>=dev-libs/libgdata-0.13.0
>=dev-libs/libgweather-3.0
>=dev-python/pyatspi-2.2
>=dev-util/anjuta-3.0
>=dev-util/devhelp-3.0
>=dev-util/gnome-devel-docs-3.0
>=gnome-base/gconf-3.2
>=gnome-base/gdm-3.0
>=gnome-base/gnome-3.0
>=gnome-base/gnome-applets-3.0
>gnome-base/gnome-common-3.7.0
>=gnome-base/gnome-control-center-3.0
>=gnome-base/gnome-core-apps-3.0
>=gnome-base/gnome-core-libs-3.0
>=gnome-base/gnome-extra-apps-3.0
>=gnome-base/gnome-desktop-3.0
>=gnome-base/gnome-keyring-3.0
>=gnome-base/gnome-menus-3.0
>=gnome-base/gnome-panel-3.0
>=gnome-base/gnome-fallback-3.0
>=gnome-base/gnome-light-3.0
>=gnome-base/gnome-session-3.0
>=gnome-base/gnome-settings-daemon-3.0
>=gnome-base/gnome-shell-3.0
>=gnome-base/gsettings-desktop-schemas-3.0
>=gnome-base/libgnome-keyring-3.0
>=gnome-base/libgnomekbd-3.0
>=gnome-base/nautilus-3.0
>=gnome-extra/at-spi-2.2
>=gnome-extra/drwright-3.0
>=gnome-extra/evolution-data-server-3.0
>=gnome-extra/evolution-exchange-3.0
>=gnome-extra/gcalctool-6.0
>=gnome-extra/gconf-editor-3.0
>=gnome-extra/gnome-color-manager-3.0
gnome-extra/gnome-contacts
gnome-extra/gnome-documents
>=gnome-extra/gnome-games-3.0
>=gnome-extra/gnome-games-extra-data-3.0
>=gnome-extra/gnome-media-2.32.0-r300
>=gnome-extra/gnome-packagekit-3.0
>=gnome-extra/gnome-power-manager-3.0
>=gnome-extra/gnome-screensaver-3.0
gnome-extra/gnome-shell-extensions
>=gnome-extra/gnome-system-monitor-3.0
>=gnome-extra/gnome-tweak-tool-3.0
>=gnome-extra/gnome-user-docs-3.0
>=gnome-extra/gnome-user-share-3.0
>=gnome-extra/gnome-utils-3.0
>=gnome-extra/gnome-weather-3.0
>=gnome-extra/mousetweaks-3.0
>=gnome-extra/nautilus-open-terminal-0.19
>=gnome-extra/nautilus-sendto-3.0
>=gnome-extra/nautilus-tracker-tags-0.12
>=gnome-extra/nm-applet-0.8.99
>=gnome-extra/yelp-3.0
gnome-extra/office-runner
gnome-extra/sushi
>=gnome-extra/zenity-3.0
>=mail-client/evolution-3.0
>=media-gfx/eog-3.0
>=media-sound/rhythmbox-2.90
>=media-sound/sound-juicer-2.99
>=media-video/cheese-3.0
>=media-video/totem-3.0
>=media-libs/clutter-1.7
>=media-libs/cogl-1.7
=media-libs/libcanberra-0.28-r4
>=net-analyzer/gnome-nettool-3.0
>=net-im/empathy-3.0
>=net-misc/networkmanager-0.8.99
>=net-misc/networkmanager-pptp-0.8.99
>=net-misc/networkmanager-openconnect-0.8.99
>=net-misc/networkmanager-openvpn-0.8.99
>=net-misc/networkmanager-openswan-0.8.99
>=net-misc/networkmanager-vpnc-0.8.99
>=net-misc/vinagre-3.0
>=net-misc/vino-3.0
>=net-wireless/gnome-bluetooth-3.0
>=net-libs/gnome-online-accounts-3
>=x11-base/xorg-server-1.15
>=x11-base/xorg-drivers-1.15
>=x11-libs/libcryptui-3
>=x11-misc/alacarte-0.13.2-r50
>=x11-terms/gnome-terminal-3.0
>x11-themes/gnome-icon-theme-3.8
>=x11-themes/gnome-themes-standard-3.0
>=x11-wm/metacity-2.34
>=x11-wm/mutter-3.0
>=sys-apps/gnome-disk-utility-3.0.2-r300
sys-apps/systemd
>=www-client/epiphany-3.0
>=www-client/epiphany-extensions-3.0

Теперь при выполнении полного обновления мира:

emerge -uDN --with-bdeps=y @world

Gnome 3 не пытается добровольно-принудительно установиться в системе.

Добавить комментарий